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Introduction

FileMaker software works well with the Microsoft Office line of products. With 

FileMaker Pro you can take a simple estimate, schedule, or contact list you created in 

Excel and drag and drop that file onto the FileMaker Pro application icon and it will 

automatically create a database in FileMaker Pro. You’ll then be able to search, sort, 

share and prepare reports using that data instantly – and without having to re-key a 

thing!

Are you creating individual letters, invoices and mailing labels by hand? Save yourself 

countless hours by integrating Microsoft Word and FileMaker Pro. By storing all your 

contacts, assets, and inventory records in FileMaker Pro, you can easily produce 

customized letters and labels by pulling information from FileMaker Pro into Word 

without having to type individual letters and invoices or duplicate data entry.

And you can use FileMaker Pro as a digital library for all your PowerPoint 

presentations as well as your Word and Excel documents and files that you use over 

and over again. By keeping frequently used templates, graphics, tables, and charts 

organized in a database, they’ll be instantly searchable and more easily accessed by 

you and anyone you choose.
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 Things you can do faster and easier in FileMaker Pro

>  Manage customer, client, and vendor details with complete searchable detail

>  Access, track, and collaborate with colleagues on projects and tasks

>  Track and manage inventory, products, and assets

>  Organize and archive pictures, video and other multimedia files or create 

your own digital asset tracking solution

>  Produce customized reports with eye-catching charts and save as PDF or 

Excel formats

>  Print invoices, letters and mailing labels

>  Send targeted mailings to customers

>  View live web information linked to your data within your database

>  Set up live two-way connections to your organizations SQL data

>  Share databases with Windows and Mac users simultaneously over the 

network or across the web. 

Before You Get Started
You will need a copy of FileMaker Pro installed on your Mac or Windows computer. You 

can get a free 30-day trial copy of FileMaker Pro at www.filemakertrial.com. On this site, 

you should also download the free FileMaker Business Productivity Kit which contains 

fully working business database templates which you can either start to use immediately, 

or customize for your own business needs.  

www.filemakertrial.com
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Let’s Get Started!

Sharing Data between FileMaker Pro and Microsoft Excel 

Strengths of Excel Strengths of FileMaker Pro

•  Storing and analyzing data in lists
•  Analyzing and modeling data
•  Producing charts and graphs
•  Building a financial model
•  Creating basic reports

•  Viewing information in list, form, or table 
    view
•  Storing and managing virtually any type of 

information (words, images, numbers, files)
•  Creating and publishing customized forms 

and reports
•  Connecting related information such as 

inventory and sales
•   Access by multiple people at the same 

time

If you’re using Excel to manage your data, you may think you have all the information 
management you need. Think again.  You can instantly transform your Excel 
spreadsheets into rich, powerful solutions that you can customize to suit your needs:

	 4Performing searches
	 4Printing professional quality reports
	 4Importing and storing images, video, PDFs, PowerPoint presentations, etc.
	 4Tracking projects, contacts, inventory
	 4Publishing information to the web
	 4Sharing data across a workgroup regardless of platform

With FileMaker Pro, you can instantly transform your Excel spreadsheets into richer, 
more powerful database solutions that let you perform searches, sort data, import 
images, create reports, add links, resize columns, and more – by simply dragging and 
dropping your Excel spreadsheets into FileMaker Pro. It really is just that simple. 

Exercise 1: Drag and Drop Import

There’s no need to re-enter the information you have stored in Excel or any other 
spreadsheet.  You can easily import your information following these simple steps.
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1. With your spreadsheet file closed, simply drag the Excel file onto the FileMaker Pro 
icon.

2.  In the First Row Option dialog box, choose whether the first row of data contains 
field names or the first record of data, then click OK. 
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3. 	In the Create a New File Name dialog box, type a name for the new file, choose a 
location, then click <Save>.

	 4You now have a FileMaker Pro file with the same information as your Excel file.

	 Once your Excel File has been converted to a FileMaker Pro file, you can now easily 
search and sort your data:

	 4Click on any header, and FileMaker Pro will automatically sort the data for you.

	 4Find information quickly by entering a word in the search box in the Status 		

	      Toolbar. Easily search across all fields in your layout.

	 4Add or delete records instantly using the “New Record” or “Delete Record”		

	      icons.

	 4Add fields or columns just like you would in a spreadsheet.

	 4Resize or re-order any column by dragging the column header to the left or 		

	      right

4. With your newly created FileMaker file, you can select any of the columns and 
easily move them around, sort them, and even use the drop down column menus 
to find sub-summary totals as shown in the following example. 
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a. 	 For this example, we want to find the total number of people in each state. To 
do this we simply click on the column menu on the State/Province column and 
select the [Add Trailing Group by State_Province] menu item.

b. 	Next, select the column menu again and choose [Trailing Subtotals] and then 
[Count (State_Province1 Count].
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c. 	 We now have a total count of the number of people in each state						   

Exercise 2:  View your data with different types of layouts

FileMaker Pro makes it easy to create layouts, forms, labels, and lists that look and 
work the way you want them to.  Let’s experiment with some new layouts and add a 
new field to our database.

1. 	To add a new field to your form, simply click on the plus sign [+] in the top right 
section of your table:



Making FileMaker Pro Your Office Companion page 10 Making FileMaker Pro Your Office Companion

2. 	Next, click in the new field box and click on the right hand arrow and choose [Field 
Type] and then [Container]. (See picture for example)

Now a Picture field has been added to your database’s list of available fields, and now 
all you need to do is insert a picture to display.

3. 	To create new layouts, simply use the “Layout/Report” button located in the top 
portion of the Layout screen (To get to the Layout screen, simply choose [View] then 
[Layout Mode] in the top menu bar).

4. Click on the [New Layout/Report] button
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5. Choose the type of layout or report that you would like to create - Standard, Table 
View, Labels, custom. For this example, we’re going to use “Standard form.”

6. On the next screen, choose what information you want to appear on your layout 
and choose [Next].

7. Next, choose what theme or color palette you would like to use and then hit [Finish].

8. You now have a new layout which you can further customize in the Layout screen.

Sample layout made from the Layout/Report Assistant

Also be sure to check out the database templates that come free with FileMaker Pro.  
There are pre-designed, ready-to-use forms for managing contacts, tracking projects, 
organizing inventory, and other popular tasks.

   
Samples of the pre-designed ready-to-use forms
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Exercise 3:  Send data as an Excel file.
There are times when you’ll want to save your FileMaker Pro data as an Excel file using 
the Excel Maker feature.

Excel Maker

Create Microsoft Excel workbooks from your FileMaker data right from within 
FileMaker Pro, for easy sharing and analysis by Excel users. 

1.  Choose “Save/Send Records As” from the File menu and choose Excel.

Save FileMaker data directly into an Excel file

2.	To view Excel options, click the Options button in the Save Records As Excel dialog.  
For example, you can define the name of the worksheet, title, subject, author, or 
enter a description about the file. 
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3.	After saving, you can automatically open the file in Excel, and/or create an email 
with the file as an attachment, or both. Just select the appropriate options at the 
bottom of the Save As dialog box.

4.	Excellent! Your FileMaker Pro data is now saved as an Excel file and presented in 
the familiar rows and columns format that Excel users appreciate. 

Exercise 4: Save data as a PDF file. 

PDF Maker
Securely share FileMaker data with people outside your FileMaker workgroup—even 
people who don’t have FileMaker—by creating, printing, and emailing Adobe® PDF files. 

1. 	Choose “Save/Send Records As” from the File menu and choose PDF to create a 
PDF file from all the records being browsed, the current record, or a blank form.

	
		             Share FileMaker data through PDF files

2.	Click the Options button to access all PDF options available from within the actual Acrobat 
application: Document, Security, and Initial View. By selecting options on the Security 
panel, for example, you can control the right to open, print, or modify the document.
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Sharing Data between FileMaker Pro and Microsoft Word 

Using FileMaker as a Data Source for a Word Mail Merge Document
It is easy to add a new letter layout within a FileMaker Pro file and print a letter to 
a single customer, a specific group of customers based on search criteria, or all 
customer records in a database.

You may however have an existing letter template in Word that you would like to 
use as the basis of a mail merge document, using customer records that are held in 
FileMaker Pro.  You can export a selected set of records from a FileMaker database, as 
a Merge file, which can be used as a recipient list for a Word mail merge document.

Step 1:  Preparing a Letter for Mail Merging in Microsoft Word

Launch Microsoft Word and open your existing letter template document:

Figure 1: A sample marketing letter written in Word, ready for merge fields to be 
added.
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Step 2:  Creating the Merge Data File in FileMaker 

You can export customer records in your FileMaker Pro database to create a new merge 
data source file.  You can either select all records in your Contacts file to include in the new 
merge file, or reduce the list of recipients by searching for a specific group of customers. 

When you are happy with your chosen set of records, select the menu option:		   
File > Export Records.

The Export Records to File dialog box will appear.  The file name and type options, are 
shown below.  Type a name for the new exported records file.  Click the down arrow 
to the right of the Save as type field and choose Merge Files from the list of file types.  
Choose a folder location to save the new merge file to, and click the Save button.

Figure 2: The file options in the Export Records to File dialog box.
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The Specify Field Order for Export dialog box will appear.  As a default setting, the list 
of fields displayed on the left, is based on the current layout.  Highlight each of the 
fields you want included in your mail merge letter, and click the Move button each 
time.  When you are happy with your selected fields, click the Export button.  A new 
merge file will now be created in the location you select.

Figure 3: The Specify Field Order for Export dialog box.

Step 3:  Linking the Merge Data File to the Merge Letter

Switch back to the letter document in Word and select the menu option Tools > Mail 
Merge Manager, or  Tools > Letters and Mailings > Mail Merge depending upon 
which version of Microsoft Word you are using. The Mail Merge task pane will open.  
Use the hyperlinks in the task pane to navigate through the mail merge process.
[See screens below for process]
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Figure 4: Selecting the Mail Merge Manager feature within Microsoft Word.

Figure 5: Select either “open data source” and choose your FileMaker Mail Merge 
document, or in newer versions of Microsoft Word, you can also choose FileMaker 
and link directly to your FileMaker database.
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Figure 6: Drag and match your database fields to the address fields in your letter.

After fields are matched, preview the records then merge the data into your letter.

Figure 7: Final letter with merged data, ready for mailing.



Making FileMaker Pro Your Office Companion Making FileMaker Pro Your Office Companion page 19

Storing and Sharing Data between FileMaker Pro and all Microsoft 
Office Applications

Use FileMaker as an Asset Library to Store Office Documents
There are many professional firms using FileMaker Pro as an electronic asset library, 
to store business documents.  You can store virtually any type of file in a FileMaker 
container field and if you have the original document application installed on your 
computer, you can open the file from within FileMaker.

Step 1:  Opening the Document Library FileMaker Template

We can use the Document Library template that ships with FileMaker Pro, to build 
an example asset library file.  Launch FileMaker Pro, and on the Quick Start Screen, 
choose the “Use a Starter Solution” section. Select the Document Library from the 
set of database templates, shown in Figure 1 below.  Click the <Choose> button to 
create the new file.

Figure 1:  Select the Document Library template from the Quick Start Screen
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Step 2:  Inserting a File into the Document Library File 

Figure 2:  Use the Document Library file to store details on a PowerPoint Presentation

The Document Library Form View layout includes a container field displayed as a 
white rectangle with the label ‘Picture’ behind it.  In addition to a description of the 
file, you can store the file itself, or a reference to it, within the container field.  Click 
the container field and choose Insert > File from either the mouse menu, or the Insert 
menu. Use the Insert File dialog box, which then appears, to select the document that 
you want to add to the FileMaker record.  

At the base of the dialog box there is a check box that gives you the option to store 
only a reference to the file, shown in Figure 3. If you select Store only a reference to 
the file, FileMaker Pro doesn’t import the file, it only keeps track of where it is on your 
hard disk, saving disk space.
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Figure 3:  The file storage option within the Insert File dialog box

When needed, you can choose Export Field Contents from the mouse menu or the 
Edit menu to export a copy of the stored document.

Step 3:  Inserting a Linked Object into the Document Library File

You may prefer to store the document in FileMaker Pro as a linked object.  This 
method means that you will be able to launch the original file from within FileMaker.

Click the container field and select the Insert File option from the mouse menu or the 
Insert menu. The Insert Object dialog box will open, as shown in Figure 4.  At the base 
of the dialog box be sure to check the box that gives you the option to store only a 
reference to the file. This will allow you to open the file within FileMaker Pro by simply 
clicking on the file in the container field

Figure 4:  Use the Insert File dialog box to add a link to the original file in a container field
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Using The Container Field

With the Container Field,  you can add, store, and archive virtually any type of file or 
information you want to your database including images, movies, sounds, Microsoft 
Office files, Adobe PDF files and much more. Store several terabytes of information in 
any single database. Use FileMaker Pro to keep track of projects, inventory, contracts, 
and store the original Word, PDF, Excel, PowerPoint or JPEG files.

Sending data from FileMaker Pro to Microsoft Exchange, Outlook 
and Entourage 

Part I Creating Emails From within FileMaker Pro

Using the Send Mail Command to Create Emails From within FileMaker Pro
It is quite easy to send email from within FileMaker Pro using the Send Mail button 
command.  From the File menu in your database, select  [Send -> Mail].
 

Figure 1:  Selecting the “Send Mail” command within FileMaker Pro
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Next, select the email field from your database, add in a subject line, message, and 
any file attachment that you wish to send.

Figure 2:  Selecting the “email field” to mail to.

Once all the fields are filled out, simply hit the “OK” button, and FileMaker will 
send the files and attachments to your email client out box.

Figure 3:  Email ready to be sent from the out box within the email client
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Next Steps

Congratulations! You’ve taken the first step toward tacking any task - the easy way!

You might be interested in the free resources available on the FileMaker websites 

(www.filemaker.com and www.filemakertrial.com). These free resources include:

•  Pre-designed, ready-to-use databases for common everyday information 

management needs.

•  FileMaker Pro Resource Center that includes video tutorials, hands-on guides and 

other helpful information.

•  Customer stories so you can read how others from around the world use FileMaker 

Pro to manage their information better.

•  FileMaker News a monthly electronic newsletter containing notifications of software 

updates, tips and tricks for using FileMaker Pro in new ways, special offers, and 

more!
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